You can skip this in seconds

Click here to continue

ChangeSender 2.90

What's Required in Version 2.90 of ChangeSender

Windows XP, Vista, 7 or Windows Server 2000, 2003 or 2008, or Windows Server SBS 2011. Any Outlook

What's New in Version 2.90 of ChangeSender

Separate sender selection for NEW emails and REPLY''s. New tool to enable/disable add-in by default. Support for large AD structures with more than one domain/site.

Look for Similar Items by Category


Popular Downloads